Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Downloading older version

  1. #1

    Default Downloading older version

    Help!
    My MacbookPro battery ran out because the power cord was disconnected and I didn't notice it … when I reconnected and started up, I was unable to open iReal Pro—message said "iReal b is damaged, delete and reinstall".
    Problem is, I can't upgrade my Macbook past Snow Leopard, so latest version of iReal Pro won't work. I was running version 6.0.1—does anyone know if and where I can download that?

  2. #2

    Default

    I have the same problem.
    I bought the program from Appstore on 2/2/2015, everything was good until today. It said that the program wa damaged and that it has to be replaced by downloading it again from th app store, but I can't do it cause it won't let me do that because of the os.

    I still use Snow Leopard and I don't wanna/can't upgrade my os in my computer. I need to be able to download an older version.
    Don't leave us alone like this!!!

  3. #3
    Join Date
    Jun 2012
    Posts
    646

    Default

    We're sorry about the inconvenience.
    There was an issue with Apple's security certificate. (more info here)
    You need to restart your computer. In case it doesn't solve the issue, delete and reinstall the app. Let us know if it works.

  4. #4

    Default

    The question still stands …
    sounds like both of us can only upgrade to Snow Leopard, meaning the highest version of iReal Pro we can install is 6.0.1, so where can we find it to download?
    In my case I have been using it without problem until now, yet my earliest available Time Machine backup from January of this year still says "iReal b is damaged and can't be opened. Delete 'iReal b' and download it again from the App Store."
    The App Store only has the latest version, which won't run on Snow Leopard …
    I'm attempting to delete iReal Pro by dragging the icon to the Trash and then emptying the Trash—is this correct? Or is there another way? I don't see any kind of de-installer thingy …
    Last edited by jazzhound; 11-12-2015 at 01:42 PM. Reason: extra comment

  5. #5

    Default

    The exact same thing is happening to me. We need to download 6.0.1 version because it's the latest that can run on Snow Leopard. Everything was perfect til today.
    I also tried to recover the app from a backup (Carbon copy cloner) but it's not working.
    I don't wanna upgrade to any other OS, and I don't need the fixes of version 6.3. We need 6.0.1 as it was working til today.

    Quote Originally Posted by jazzhound View Post
    The question still stands …
    sounds like both of us can only upgrade to Snow Leopard, meaning the highest version of iReal Pro we can install is 6.0.1, so where can we find it to download?
    In my case I have been using it without problem until now, yet my earliest available Time Machine backup from January of this year still says "iReal b is damaged and can't be opened. Delete 'iReal b' and download it again from the App Store."
    The App Store only has the latest version, which won't run on Snow Leopard …

  6. #6

    Default

    Just so you know: Running iRP 6.3 on iMac OSX 10.7.5. When I booted up this morning, iRP (and one other app so far) prompted me to "reinstall" from the AppStore because it was "purchased from another device" (which it wasn't). Logged in with my AppleID and the app was instantly restored - didn't need to reinstall anything, and didn't lose any files. I know this doesn't solve the Snow Leopard problem, but just wanted others to know the Apple security glitch was a minor nuisance, but not fatal.
    There's two kinds of mistakes you can play: The ones you notice, and the ones somebody else might notice.

  7. #7
    Join Date
    Jun 2012
    Posts
    646

    Default

    We contacted Apple about the issue and they asked us to tell our users to contact their support team since the problem is not on our side.
    However, we don't want our users to be without iReal Pro while they fix the problem so in case you have OS 10.6.8, please email us at support [at] irealpro.com and we will provide you with another version of the app.
    We are sorry about the inconvenience.
    Last edited by Niki; 11-12-2015 at 06:17 PM. Reason: Updated info

  8. #8
    Join Date
    Mar 2013
    Posts
    2

    Default

    I had the same "iReal b is damaged, delete and reinstall" issue today as well. Strangely, this has happened on BOTH drives that I had iReal installed on. Is this a virus? I'm running OS 10.6.8 on a Mac pro. I can't find anywhere to download the earlier version. Bummed. I LOVE iReal. It's a practice tool that I use every day!

  9. #9
    Join Date
    Nov 2014
    Posts
    1

    Default I am in trouble with irealpro

    Hi,Niki
    I am Keiko. I am useing OS 10.6.8 . I use iReal Pro everyday with my piano. So please tell me how to get the iReal pro.

  10. #10
    Join Date
    Jun 2012
    Posts
    646

    Default

    Quote Originally Posted by wungy View Post
    I had the same "iReal b is damaged, delete and reinstall" issue today as well. Strangely, this has happened on BOTH drives that I had iReal installed on. Is this a virus? I'm running OS 10.6.8 on a Mac pro. I can't find anywhere to download the earlier version. Bummed. I LOVE iReal. It's a practice tool that I use every day!
    Just email us at support[at]irealpro.com to resolve the issue.
    Thank you!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Do you have any questions?

Check out our Support page

Sign up to our newsletter
Join us